Wireshark on Ubuntu 12.04.03

The latest version of wireshark has been ported to GTK+3.0. However, I could not run configure in my Ubuntu 12.04.03 LTS, because it cannot find GTK3.0 properly installed. It seems GTK+3.0 should be installed by default (not sure though).

Search around, I found someone suggest install libgtk-3-dev. However, it failed again with the following information:

The following packages have unmet dependencies:
libgtk-3-dev : Depends: libpango1.0-dev (>= 1.30.0) but it is not going to be installed
Depends: libcairo2-dev (>= 1.10.0) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

This is another problem which I could not fix. Most solutions online I could find do not work for me. for example, many people suggest use synaptic by ‘edit->fix broken package’. Also, ‘apt-get clean & apt-get update’ does not fix the problem.

Back to wireshark, at last, I have to give up GTK+3.0 and run configure with –without-gtk3 and –with-qt.

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s